Just this morning, a critical new vulnerability in WPA2 called KRACK has been publicly announced. Contact your WiFi manufacturer support to determine if a patch is available yet. Manufacturers were made aware of this vulnerability in August 2017, so I hope they have patches available.

For more information:

https://arstechnica.com/information-...eavesdropping/

Regards,

Ernest Aleixandre